奇迹大师等级经验计算方试易语言源码

来源: 作者: 点击:
版本 2

.子程序 SetExperienceTable
.局部变量 local3, 长整数型
.局部变量 local5, 长整数型
.局部变量 local7, 长整数型
.局部变量 local8, 整数型

重定义数组 (m_i64ML_ExperienceTable, 假, GSIni.MAX_MASTER_LEVEL)

.判断循环首 (GSIni.MAX_MASTER_LEVEL > local8)
local8 = local8 + 1
local3 = local8 + 400
local7 = (local3 + 9) × local3 × local3 × 10
local5 = local3 - 255
local7 = local7 + (local5 + 9) × local5 × local5 × 1000
local7 = (local7 - 3892250000) ÷ 2
m_i64ML_ExperienceTable [local8] = local7
.判断循环尾 ()

.子程序 CalculateNexExp, 长整数型
.参数 MasterLevel, 整数型
.局部变量 MLNextExp, 长整数型

MLNextExp = m_i64ML_ExperienceTable [MasterLevel]
返回 (MLNextExp)
栏目列表